Reply
Reply
 
Thread Tools Display Modes
Husch's Avatar
Old (#1)
I have a problem with a 3DS Max 9 scene which file size increases each time I save it. There was a script or command for older Max versions to clean the scene from garbage. But I can´t remember it. Can anybody help me?
Offline , spline, 106 Posts, Join Date Oct 2004,  
   Reply With Quote

Husch's Avatar
Old (#2)
OK, when I wrote the question I remembered the word "garbage" and a google search gives me the Max Lister command gc(). Unfortunately it doesn´t do the trick. Any other idea to reduce the file size of a saved Max scene? The scene consist of three Characters of moderate polycount (around 5000 Polys) and two Bipeds and a bone rig. The file size is around 130 MB.
Offline , spline, 106 Posts, Join Date Oct 2004,  
   Reply With Quote

perna's Avatar
Old (#3)
No help from me. All I can say is I've run into the problem of huge file sizes with simple models and would like to know what's up with that as well.
Offline , veteran polycounter, 4,830 Posts, Join Date Oct 2004, Location UK Send a message via ICQ to perna Send a message via MSN to perna Send a message via Yahoo to perna  
   Reply With Quote

Rick Stirling's Avatar
Old (#4)
Create a new scene, then merge all the objects from the bloating scene.

If you don't mind losing all the materials and adding them again aftrwards, sometimes clearing them can help the bloat.

Clear all the materials from the editor:
for i = 1 to 24 do
(
meditMaterials[i] = Standardmaterial ()
)


Then cleanse your scene:

max select all
$.material = undefined
Offline , veteran polycounter, 4,273 Posts, Join Date Oct 2004, Location Edinburgh, Scotland Send a message via MSN to Rick Stirling  
   Reply With Quote

Eric Chadwick's Avatar
Old (#5)
Apparently a known issue at Autodesk. From the sp2 readme...

[ QUOTE ]
File I/O:
• Files saved in 3ds max 9 can grow in size when compared to previous versions of 3ds max.

[/ QUOTE ]
Offline , Moderator++, 7,607 Posts, Join Date Oct 2004, Location Boston USA  
   Reply With Quote

conte's Avatar
Old (#6)
gc();
Offline , veteran polycounter, 2,731 Posts, Join Date Feb 2006,  
   Reply With Quote

MoP's Avatar
Old (#7)
Conte, that's a pretty useless answer, since if you'd read the 2nd post, you'd know he's tried that.
Also, you should realise that if he didn't know about it, then it's still useless, since it doesn't explain anything about how to use the command, or what it's for.

Think a bit more before posting, please! I know you're trying to help, but it only works if you actually make sense and think it through [img]/images/graemlins/smile.gif[/img]
Offline , MoP, 11,623 Posts, Join Date Oct 2004, Location London, UK  
   Reply With Quote

fritz's Avatar
Old (#8)
in reference to the gc() thingy...a friend of mine says that people at his studio have to go through a couple of steps before entering in the "gc()" thingy. don't know if it will work...but worth a try.

first go to: file > Xref objects > close the window
then go to: file > Xref scenes > close the window

the enter: gc() in the pink tab at the bottom left side of the max window.
Offline , polygon, 675 Posts, Join Date Aug 2005, Location chicago IL  
   Reply With Quote

Mark Dygert's Avatar
Old (#9)
I'm guessing its one of two things.

1) Max crashed and you started using the file it tried to recover when it crashed. When it says "max will ATTEMPT to save your scene, but we don't think it will work... ever..." they mean it. Just use an autoback or previous save. Or do like what Rick suggested and merge it all into a new scene. If you only had a mesh in your scene I would suggest exporting it to .OBJ, and import that into a new fresh scene. That works really well at dumping any weird data Max has attached to a file.

OR

2) It's BiPed.
The fast way to check if its extra BiPed data is to delete all bipeds and save, see if the file size drops drastically, if it does your issue might be a broken biped or a ton of biped pose/posture/track collections you didn't know you had.

With a BiPed object selected go to the motion tab (wheel) under the copy/paste roll out look to see if you have a bunch of collections you didn't mean to have. More than likely if this is the case you accidentally hit hot key for auto capture collections or turned it on by mistake at some point.
(AKA Vig) Portfolio | Lab | Brawl | Decker |
Offline , Polycount.com Editor, 14,564 Posts, Join Date Oct 2004, Location Seattle, Wa Send a message via MSN to Mark Dygert  
   Reply With Quote

conte's Avatar
Old (#10)
sorry, Paul, you right.
fritz did my job ya!
Edit: Just hide all models before saving, that should help.
Also if you're hiding layers in photoshop, file will weight less too. (that told me J.Styles, long time ago)
Offline , veteran polycounter, 2,731 Posts, Join Date Feb 2006,  
   Reply With Quote

MightyPea's Avatar
Old (#11)
Conte: isn't that just because of the 'full resolution composite', or is there something stranger going on?
Artist at Interwave Studios | Polycount Wiki | Portfolio |||<
Offline , veteran polycounter, 3,308 Posts, Join Date Oct 2004, Location Amsterdam Send a message via MSN to MightyPea  
   Reply With Quote

conte's Avatar
Old (#12)
Pea, dunno really=)
but it works!
Offline , veteran polycounter, 2,731 Posts, Join Date Feb 2006,  
   Reply With Quote

Joshua Stubbles's Avatar
Old (#13)
Fritz - yeah, I had to do that exact same thing when working on Stacked. Our scenes would bloat to 50MB or so, then we'd run that process, and drop us down to about 6-7MB again.
Funny thing is, we got that nice tidbit from our 3dsmax reseller agent. This was back with Max7. If they knew about it, I wonder why the hell Autodesk hasn't fixed it yet.
[vassago] env artist, Turn10 Studios
portfolio - linkedin -
polycount.wiki
Offline , Moderator++, 6,277 Posts, Join Date Nov 2004, Location Redmond, WA Send a message via ICQ to Joshua Stubbles  
   Reply With Quote

fritz's Avatar
Old (#14)
dunno. i have heard from lots of people that the files bloat due to excessive merging of objects n' stuff. i think there are lots of things autodesk could fix in max. haha.
Offline , polygon, 675 Posts, Join Date Aug 2005, Location chicago IL  
   Reply With Quote

Rick Stirling's Avatar
Old (#15)
[ QUOTE ]

Funny thing is, we got that nice tidbit from our 3dsmax reseller agent. This was back with Max7. If they knew about it, I wonder why the hell Autodesk hasn't fixed it yet.

[/ QUOTE ]

Perhaps it just never made it into the codebase?
Offline , veteran polycounter, 4,273 Posts, Join Date Oct 2004, Location Edinburgh, Scotland Send a message via MSN to Rick Stirling  
   Reply With Quote

Joshua Stubbles's Avatar
Old (#16)
Could be, Rick. But still, after like 2 years or so you'd think they'd nail that one.
[vassago] env artist, Turn10 Studios
portfolio - linkedin -
polycount.wiki
Offline , Moderator++, 6,277 Posts, Join Date Nov 2004, Location Redmond, WA Send a message via ICQ to Joshua Stubbles  
   Reply With Quote

Husch's Avatar
Old (#17)
Thanx a lot to all of you! Vig, you saved my day. It was the biped and the auto collection. I deactivated the "Load Collection" Option in the copy/save rollout "Max Load Preferences".Then I loaded and saved my scenes again and it reduced the file size from 129 MB to 9 MB.
Offline , spline, 106 Posts, Join Date Oct 2004,  
   Reply With Quote

MoP's Avatar
Old (#18)
Hah, nice one - worth remembering.
Offline , MoP, 11,623 Posts, Join Date Oct 2004, Location London, UK  
   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 1998-2014 Polycount