Author : AneeshaRode


Reply
Reply
 
Thread Tools Display Modes
Emi Ayaka's Avatar
Old (#1)
Hello, I've been trying to work out my normal map problems for about 5 days now. I am getting seams where the uv seams are from viewing with just the (tangent space) normal map applied in marmoset 2. My UVs were unwrapped in Maya. They are mirrored correctly as well (I've tried a version without mirrored UVs as well). There have been many things I have tried. I have baked the normal from different programs: Maya, Zbrush, and Xnormal. Using a cage as well as trying without a cage in Maya and XNormal. All results still showed seams. I also made sure to bake the final complete model when I baked every time (didn't try to bake half of normal and mirror it). I've also made sure that my vertices were all welded together on the model. The model has also been softened in Maya before baking. Tried padding (dilating) the normal maps. I've went into Photoshop and tried to blur out the edges as well with the neutral blue normal map color (tried combining that with padded version as well (always made sure to normalize when done)). I've been using .tga files (I've tried 32b, 24b, and 16b (with and without the alpha channel). Attempted flipping the Y in Marmoset too. The seams are still there.

Any information towards this would be greatly appreciated. Thank you for your time!



Seam down the middle of chest


Closer view of chest seam


Closer view of chest seam with version I've taken into photoshop and blurred out the edges


Example of my padded normals rendered from XNormal


Example of normals with edges marked out with normal map neutral blue


I've also gotten some seams where the edges of some of my polygons are.
Offline , null, 3 Posts, Join Date Aug 2014,  
   Reply With Quote

sargentcrunch's Avatar
Old (#2)
The first thing to try is setting your tangent space in Marmoset to XNormal.
Offline , triangle, 481 Posts, Join Date Jul 2011,  
   Reply With Quote

Emi Ayaka's Avatar
Old (#3)
Quote:
Originally Posted by sargentcrunch View Post
The first thing to try is setting your tangent space in Marmoset to XNormal.
I tried it out, I didn't notice any differences in my situation. I wasn't aware that you could do that in marmoset until now, very interesting. Thanks!
Offline , null, 3 Posts, Join Date Aug 2014,  
   Reply With Quote

EarthQuake's Avatar
Old (#4)
Try using fbx, or obj if already using fbx.
Offline , Moderator, 10,324 Posts, Join Date Oct 2004, Location Iowa City, IA  
   Reply With Quote

almighty_gir's Avatar
Old (#5)
Just to double check what you're saying about "mirrored correctly", have you offset the mirrored UV's by 1?
Offline , insane polycounter, 5,854 Posts, Join Date Nov 2004,  
   Reply With Quote

ahmed mohamed's Avatar
Old (#6)
im ether need help hello guys how are you i`m does any one know how can the uv showing up in my x normal i have a problem on this , evry time i export my 3ds to obj or the x normal format , to the x normal i do see random uv not the one that i created and my backing just messed up with very nasty uv ... i have to mention that i use 3dmax 2009
Offline , spline, 128 Posts, Join Date Feb 2014, Location sudan  
   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 1998-2014 Polycount