PDA

View Full Version : nDo2 to UDK ?


Linkitch
02-15-2012, 09:31 AM
Alright, I'm new to both UDK and nDo2. And I'm having some problems.

I've created a bunch of normal maps directly with nDo2, rather than baking anything. Problem is they seem to give me some lighting problems in UDK.

I took a normal map from a tutorial I'm following on UDK materials and noticed that when imported into UDK my own normal map and the one from the tutorial look different, once in the material editor:

http://i.imgur.com/wyYNE.jpg

So can anyone tell me what exactly I need to do, to set up a normal map created with nDo2 to work with UDK?

WarrenM
02-15-2012, 09:44 AM
When you imported it, did you select TC_NormalMap in the import dialog?

Linkitch
02-15-2012, 10:11 AM
When you imported it, did you select TC_NormalMap in the import dialog?
Apparently I didn't, since I had heard and read you could simply change that afterwards and re-import. I now know that setting is totally broken and no longer trust it.

But thanks.

WarrenM
02-15-2012, 10:18 AM
You CAN change it afterwards but you have to change a few other things as well. It's just easier to do it at import time. :) From then on you just can right click it and "Reimport Texture" which will remember the settings you last used on it so it's only the first time that you have to remember.

Linkitch
02-15-2012, 02:00 PM
You CAN change it afterwards but you have to change a few other things as well. It's just easier to do it at import time. :) From then on you just can right click it and "Reimport Texture" which will remember the settings you last used on it so it's only the first time that you have to remember.
Could you elaborate as to what other settings you also need to change, if you do it the "hard" way?

WarrenM
02-15-2012, 02:05 PM
I don't know specifically. All I know is that I watched someone try it and give up. It's just easier to import the texture again, fresh, with TC_NormalMap selected.

Ace-Angel
02-15-2012, 04:16 PM
Disable SRGB and it should solve most of your issues.

cptSwing
02-16-2012, 12:50 PM
yeah, disable SRGB, set unpack_Min to -1 on all channels, and then play around with either TC_Normalmap or TC_NormalmapUncompressed (the latter halves the resolution and mathematically reconstructs the blue channel in exchange for not compressing the texture).