PDA

View Full Version : Weird problem when baking AO


3Dyan
09-07-2011, 04:23 PM
I'm trying to bake a lighting map to be used as AO but I ran in a bit of trouble.

It seems that wherever the highpoly mesh intersects with the low poly mesh I get an ugly seam.

Example:
http://i52.tinypic.com/332nnm9.jpg

Anyone knows a way to be rid of this other than pushing all of my high poly inside the low poly?

aajohnny
09-07-2011, 06:28 PM
Are you using 3ds max? and may you post the model showing lp and hp with cage?

3Dyan
09-07-2011, 06:48 PM
Yes, I'm using max, forgot to mention it.

Here is the area that corresponds to the shot I posted.

http://i52.tinypic.com/n6uusl.jpg

You can see those bunny ears and that rib poking out in the AO bake posted above.

gsokol
09-07-2011, 07:14 PM
Well...the spots where your high poly geo stick out of the cage are probably causing some wonkiness. Do you have ray miss check turned off? Pop that on and you will likely get errors there. That is potentially the cause of your AO wonkiness.

Your cage needs to contain your hp model, the cage represents the limits of raycasts, and everything on the outside will be ignored.

3Dyan
09-07-2011, 07:19 PM
The cage wraps everything up nicely. No red spots.
When I baked the normal map it turned out fine.

By the way. This happens with Mental Ray as well.

P.S. I circled those two areas because they are the ones you see in the flat shot. This actually happens wherever the HP pops through the LP.

ScottJ
09-07-2011, 08:12 PM
try making your low poly transparent, I had this issue too, I think that's how I solved it.

Ace-Angel
09-07-2011, 11:21 PM
Does it happen with light-tracer or mental-ray only?

Mental Ray needs (in some cases of Max) a hidden mesh (select all faces in sub-object and 'hide').

If you have time, try xNormal, always a good way to proof test any bakes.

3Dyan
09-08-2011, 04:50 AM
Mental Ray needs (in some cases of Max) a hidden mesh (select all faces in sub-object and 'hide').


That did the trick for mental ray. Thanks!

I wonder if there is a way to solve this problem with light tracer...
Hiding the mesh didn't work for that one.