PDA

View Full Version : 3dsMax 2010 - Skylight/Light Tracer issue


gsokol
09-02-2011, 06:07 PM
Hey all,

I ran into an issue and I'm hoping somebody has some insight.

Basically...renders from the scanline renderer with a single skylight and light tracer stopped rendering shadows.

In Viewport:
http://i81.photobucket.com/albums/j203/white99stang281/rendercorrectlyassholefrommax.jpg

Render:
http://i81.photobucket.com/albums/j203/white99stang281/rendercorrectlyasshole.jpg

I've had this happen before, but restarting my PC and/or importing all objects in scene into a new one fixed the issue...this time that is no longer the case.

Like last time, this happened after switching from mental ray to scanline.

This is stopping me from being able to bake a lightmap/AO map. Has anybody ever came across this?

Oniram
09-02-2011, 06:40 PM
sometimes when i switch from scanline to mental ray and back the light tracer settings get switched. make sure light tracer is active, and that its referencing your skylight.

gsokol
09-02-2011, 07:08 PM
Yup, Light tracer is active. As far as I know it should be referencing the skylight.

Even if I make a new scene and drop in a skylight and turn on light tracer, I get the same results.

r_fletch_r
09-03-2011, 12:48 PM
The mesh doesnt look like its likely to cause much occlusion, all the indents are shallow and pretty much 90% exposed. try sticking in a few bits of basic geometry like a teapot on a ground plane and see how they look. that way you can tell if the occlusion is working or not.

Stromberg90
09-03-2011, 01:50 PM
r_fletch_r: I think you are right on the money here, cause I took the image and adjusted the levels in photoshop, and the AO is there but not very noticeable.

gsokol
09-03-2011, 03:06 PM
r_fleth_r and Stromberg90,

you guys are right. I loaded up a more complicated mesh and it rendered fine. Guess I was just expecting something different.

Thanks for the heads up.

r_fletch_r
09-04-2011, 06:55 AM
You can still get what you were expecting but you need to use mental ray.
bake a mentalray AO map. and increase the spread angle until you get your details. usually 1.1 or 1.2 should get what you want. keep in mind though that going above one can cause faces to occlude themselves which will lead to faceting.

heres a gif of MR AO, I've animated the spread angle from the default of .75 to 1.2 so you can see the effect.

http://dl.dropbox.com/u/30581169/spread_0000.gif

heres a shaded version of the mesh.
http://dl.dropbox.com/u/30581169/cube.jpg

gsokol
09-06-2011, 08:26 PM
Cool man, thanks for tip!