PDA

View Full Version : max snap vertex to grid issue


easterislandnick
09-02-2011, 08:07 AM
I am having issues snapping verts to the grid in max, they always snap from a relative position to the grid, if a vert is a few pixels from a grid point and I snap them to another grid point then they are a few pixels from that grid point.

In other posts it's suggested that you have to snap the object pivot to the grid but I still get the same issue.

Any ideas, I have snap to Grid points and Vertex ticked in the grid and snap settings and get the same problem in snapping in 2d, 2.5d and 3d modes.

Mark Dygert
09-02-2011, 08:23 AM
What version of max are you using?
I remember in past versions what a pain it was to snap and the trouble with the offset you are describing... hated it with a passion, but since they overhauled it, I can't complain, its perfect.

They reworked snaps in 2011 or 2012 so they aren't as jacked up as they used to be. They added a round point to the gizmo that actually snaps to the vert. In the past I think it would select the vert but the position would be based on where your mouse was so if you where a few pixels away from the vert and still able to select it, it would grab it but be offset, what a mess that was. I think if you turned down your "snap preview radius" it would help make it a bit more precise but it wasn't fixed perfectly until 2011-2012.

Also in past versions, whatever you have max set to for units would effect snap precision quite a bit. Snaps liked standard max units and didn't play very well with US standard or metric, especially if you started working on a small scale.

WarrenM
09-02-2011, 10:19 AM
FWIW, 2012 seems to have fixed all the snapping problems I've had in the past. It does exactly what I want it to, every time now.

easterislandnick
09-05-2011, 02:21 AM
I'm using 2010 at work and won't be able to upgrade for this project, this is driving me nuts though...... but now it's working, I didn't change anything? Did max just need a break over the weekend?