View Full Version : Maya viewport not updating automatically?

09-01-2011, 01:26 PM
I've been having a recurring problem in Maya 2011 for a while now, not sure what it's due to, probably some command I use, but I really can't seem to identify what it is.

Regularly my viewport will stop updating automatically unless I turn or move in it.
For instance I'll switch to vertex component mode on an object, I'll see the vertices appear if I move slightly in the viewport. Same for most operations, for instance, even if I click select an edge, I have to move slightly before I see it's highlighted.

Sometimes it goes away by itself after a while, otherwise I have to reboot Maya.

Anyone come across a similar problem? Really don't understand what I could be doing to trigger this.

09-02-2011, 05:38 AM
One of the animators here is having exactly the same issue. We're also having trouble tracking down exactly what causes it. At first I thought it may be to do with an export script which may have been disabling redraw but it seemed to happen recently even without running any of these scripts.

I'm currently thinking it may be graphics card/driver related as that machine has a different graphics card to the others which have not had this issue. We may try updating the driver and see if that fixes it. I'll let you know if it does. I'll also be interested to see if anyone else has solved this already.

09-02-2011, 05:44 AM
I have been playing with 2012 x64 at home (w7 x64) a little bit and had this issue happen to me a handful of times too.
I have yet to pin point exactly what's been happening but everything goes fine when I restart Maya.
I was also leaning on the drivers/windows update shit side so far. I am running a GTX260 btw.

09-02-2011, 07:01 AM
I had this bug in different version of maya, never found exactly how to solve the problem. First time appering after a graphic card driver update I think.
I've never really managed to get rid of it even by reverting my old drivers.
Eventually the problem was solved when I changed my graphic card...

09-02-2011, 07:20 AM
I don't think it's a graphic card or driver issue in my case, it does it on the 4 computers I've used recently (2 at home, 2 at work) with quite different hardware/drivers in them, so I really think it's more of a problem with one of the commands I use, disabling the viewport update somehow...
I know 3dsMax has a shortcut to do this , which often new users often get, but I can't find any kind of equivalent in Maya.

09-02-2011, 07:50 AM
I've had this problem on multiple computers, Maya 2010 and 2011. Never figured it out...

09-02-2011, 11:38 AM
I've had it a handful of times, but never regular enough to try and troubleshoot it. I recently did a hardware change, and now I have something similar though. Using the gradient background, after some arbitrary edit to a model, I can't see anything. Sometimes un/reselect the model fixes it until the next click.
I can avoid the issue by alt-b'ing to one of the solid backgrounds, maybe that will work for you?

10-22-2014, 03:25 PM
Still having this problem with Maya 2015

07-07-2015, 03:56 AM
And still having in 2016. There must be some way to force this to correct itself? I also notice when it does this that if you press ctrl+q to quit or try to quit, it doesn't work. Also the tools menu doesn't update with the currently selected tool's options.

I've seen this bug all the way back to at least 2010, and have it happen at least a few times a week at work and at home (so different machines), not to mention I only recently updated to a new PC.

If it really is display driver issues as so many say it could be liked to, I've had:
9800 GTX
GTX 560ti
GTX 980 (current)
Quadro K2000 (at work)

Resetting preferences etc, etc, etc does nothing for it.

I take it there is no MEL command to force the UI and to redraw or something? And the viewport?