PDA

View Full Version : [3ds max 2011] Frustrating lag when changing sub-object modes


Minos
08-24-2011, 07:36 PM
Hi guys,

I've been having this problem for a while now. It happens on 3ds max 2009 too: I get a horrible lag when changing sub-object modes or when selecting an object for the first time. 3ds max just freezes for a second or so. It feels like 3ds max is having a hard time populating the rollouts, it flickers for a while but it's not visible in the video:
http://www.youtube.com/watch?v=N2gconNzxng

What I have tried so far:
- Disabling aero
- Doing a fresh install of the latest gfx drivers
- Removing all 3rd-party plugins
- Tried DX10, same problem

A friend with a slightly inferior CPU and similar RAM/same GPU didn't notice this behavior at all on his PC.

Anybody experienced this before and knows a fix for it?

Thanks

Mark Dygert
08-24-2011, 08:00 PM
wow that's pretty bad. It reminds me of the ribbon lag when first launching it. It also reminds me of the lag when closing the UV editor in 2012... what where we talking about again? Oh yea it might be some kind of software conflict with something else that is running in the background.

Do you have any driver software that forces FSAA?

How about monitor management software like ultramon?

What kind of hardware are you running? If you can run DX10 I guess it can't be that bad.

Minos
08-24-2011, 08:52 PM
wow that's pretty bad. It reminds me of the ribbon lag when first launching it. It also reminds me of the lag when closing the UV editor in 2012... what where we talking about again? Oh yea it might be some kind of software conflict with something else that is running in the background.

Do you have any driver software that forces FSAA?

How about monitor management software like ultramon?

What kind of hardware are you running? If you can run DX10 I guess it can't be that bad.


I'm on a Q6600, 4GB and a 9800GT 512mb video card. I tried DX 10 but it's pretty buggy so I reverted to DX 9. It didn't fix the problem anyway.

Earlier today I downloaded a software that shuts down all unnecessary processes and background softwares, still had the same problem. This is driving me nuts.

joebount
08-25-2011, 01:34 AM
Windows 7 or Vista ? if so, you might want to disable Aero.

ParoXum
08-25-2011, 01:55 AM
Did you set a custom background in your viewport? I had that on 2010 when using a custom background gradient. Got rid of it

fonfa
08-25-2011, 05:20 AM
I have that on 2010 all the time. That's the main reason why I prefer to work on 2009 :(

[HP]
08-25-2011, 05:30 AM
What is that vignette effect on the viewport? Are you using anything fancy on the background? Get rid of all the shit you might have installed.

Have you tried running with opengl?

GeeDave
08-25-2011, 05:34 AM
I get this as well... except mine "flickers" for the duration, as opposed to the lag. I raised the issue on another forum a while back, like... years ago. A lot of people had the same issue and we never did work out how to stop it.

I've sort've just learnt to "deal with it".

BeatKitano
08-25-2011, 05:45 AM
Or just hide the command panel forever and don't have to deal with it. I love custom uis.

perna
08-25-2011, 07:42 AM
I've sort've just learnt to "deal with it".

Holy crap.

Anyway, I had this problem and solved it 100%. Max 2009 UI is super slick now on Win7 64. Shut down other software with a UI (background processes don't matter), particularly browsers with lots of tabs.

The more apps are running with the same kind of UI libs/handling/rendering, the slower max will run.

Max 2010 and above UI runs ridiculously much slower than 2009, though. But that's more by "design" than a bug.

Minos
08-25-2011, 10:07 AM
I don't have aero enabled and I disabling the viewport image didn't help either.

HP: OpenGL didn't make any difference either.

@GeeDave: Yeah it flickers too but it's not really visible on the video.

I've just tried to run on Expert Mode, didn't make any difference too...

I found another guy on youtube with the same problem:
http://www.youtube.com/watch?v=gPm-fimbY7c

perna
08-25-2011, 10:23 AM
I found another guy on youtube with the same problem:
http://www.youtube.com/watch?v=gPm-fimbY7c

that other guy just posted in this thread with the solution :)

Minos
08-25-2011, 10:26 AM
that other guy just posted in this thread with the solution :)

lol

Yeah, closing all other programs improves the situation by 50% or so, but doesn't really solve the problem. Is the lag completely gone for you when you close everything else?

perna
08-25-2011, 10:33 AM
lol

Yeah, closing all other programs improves the situation by 50% or so, but doesn't really solve the problem. Is the lag completely gone for you when you close everything else?

Try to aggressively close everything you can find, in the task bar, through the task manager. No matter if you need it, at this stage you just want to find the maximum speed improvement then worry about being selective later (as only some programs affect the speed).

My ui lag is completely gone on 2009 (it's completely instant, especially with 3ds clean installed). All versions since that have massive UI render speed problems, however. That's just something people have to deal with (enabling aero works in some cases)

IchII3D
02-14-2012, 12:04 PM
Aha! I found the solution to this issue! Its got nothing to do with closing apps, although I found that helped a tiny tiny bit. To remove the problem altogether check what Windows 7 theme your using, I was using Windows Basic as I assumed it was faster. But it looks to cause this issue, switch to Windows Aero Transparency or whatever its called and the problem is magically gone!

Hope someone is around to read this as I personally have being putting my head out for months!

BeatKitano
02-14-2012, 01:02 PM
Don't want to be an ass but

"That's just something people have to deal with (enabling aero works in some cases)"
Perna 8-25-11


"But it looks to cause this issue, switch to Windows Aero Transparency or whatever its called and the problem is magically gone!"
Ichll3D 02-14-12

IchII3D
02-15-2012, 01:18 AM
http://500motivators.com/plog-content/thumbs/motivate/me/large/402-facepalm-your-doing-it-wrong.jpg