PDA

View Full Version : [Maya] Some objects/sub-objects not visible on all viewports?


Minos
08-17-2011, 12:56 PM
Hi,

I recently started to learn Maya and I have run into a very annoying issue: Some objects/sub-objects are not visible on all viewports sometimes.

Notice how the gizmo is visible in all viewports but the top view. I can still manipulate the face in the top view but the wireframe/gizmo is not visible. Very annoying:
http://i.imgur.com/1DBXZ.jpg



Another object selected. Gizmo still not visible in the top view:
http://i.imgur.com/j8OpC.jpg



However, if I select this other object the gizmo is visible in all viewports:
http://i.imgur.com/NjHQY.jpg



Another quick question: Coming from Max I noticed that Maya has "ignore backfacing" on out of the box. I've tried several different options but I just can't get rid of this damn thing. It's very annoying because I rarely use "ignore backfacing" in my workflow. I have tried enabling backface culling but that's not what I want really. Anybody knows how to get around this?

Thanks in advance.

Gilgamesh
08-17-2011, 01:31 PM
There are enable backface culling for display and for selection as far as I know. One is part of rendering (should still show up on skeleton mode) and the other is a option in the preferences. Make sure both are off. I upgraded to Maya 2012 and it come with the preferences option as on by default and it bugged the hell out of me and took me a good few minutes to find the option to turn it off.

Also I've sometimes had that the face is too far away from the camera to be viewed (and then selected) I see you're using large unit-sized buildings so that could also be the problem (set up your cameras view range to allot further.

Jeff Parrott
08-17-2011, 01:48 PM
Seems like your gizmo issue is either due to the camera clipping planes or pivot placement (seems odd to be that). You can try going into the view menu in your top/side/or front view window and select camera attribute editor. Adjust the near/far clip planes if needed.

Are you trying to have backfaces viewable or not select polys that aren't visible?

Shading>backface culling in the top/side/or front view window is where you'd find that. I think there is a way to have it globally on. But I'm blanking at the moment on it.

Joopson
08-17-2011, 01:50 PM
It could also be too close to the camera, as stupid as it sounds. I've had my rotate tool appear all wonky, because of that. To check, in the bad-viewport, go to view>select camera, and then go to another viewport, and move it away from the mesh in whatever axis is appropriate.

Minos
08-17-2011, 01:56 PM
It could also be too close to the camera, as stupid as it sounds. I've had my rotate tool appear all wonky, because of that. To check, in the bad-viewport, go to view>select camera, and then go to another viewport, and move it away from the mesh in whatever axis is appropriate.

That solved the problem, thanks very much :)

@Jeff: I want to select ALL vertices (that is, turning ignore backfacing off). If there's an option to toggle this on and off globally that would be sweet.

Editing: Well, moving the planes has also fixed this issue. I was not able to select all vertices before because some of them were behind these "camera planes".

tharle
08-17-2011, 02:37 PM
shift right click with nothing selected and go down to polygon display > backface culling on/off for all polys should work i think.

you can also do it per object if you have an object selected using the same method.

if you dont like the right click marking menus you suck...

or can just go up to display > polygons > backface culling but that only seems to work for the objects selected not the whole scene.

anyway that display menu is where you find all the settings etc. if you just want to cull somethings etc. i've never played with it too much as the default settings always seem to work for me

Jeff Parrott
08-17-2011, 03:39 PM
It's in Preferences>Selection>and click on Camera based selection

selectPref -useDepth false; //drag that to a shelf button and that will turn off the camera based selection.

selectPref -useDepth true; //drag that to a shelf button to turn that on.

If you want it to toggle talk to Mop. He's the man with scripting.

haiddasalami
08-17-2011, 04:21 PM
if(`selectPref -q -useDepth` == 1){
selectPref -useDepth false;
}
else {
selectPref -useDepth true;
}


There ya go. Toggles on and off camera selection.

Minos
08-18-2011, 05:56 PM
Thanks everyone!


if(`selectPref -q -useDepth` == 1){
selectPref -useDepth false;
}
else {
selectPref -useDepth true;
}


There ya go. Toggles on and off camera selection.

Thanks a bunch, that works like a charm :)

This camerabased selection is quite funky imo. I still can't wrap my head around this concept. Here's what happens when I turn it on (I'm doing marquee selections in these screenshots):
http://i.imgur.com/DrHuC.jpg
http://i.imgur.com/HEGc4.jpg

It works for some verts but for others don't? It's not a problem with the camera plane either, I moved the mesh around and the behavior persisted.

Jeff Parrott
08-18-2011, 06:42 PM
That seems like it's clipping plane related. Maya is pretty screwy with this stuff honestly. At least the vert snapping works though.